ClientTell SMS Delays
Incident Report for TeleVox
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 11:24 CDT
Monitoring
**Attention Clients** Reminder Manager notifications were delayed from being delivered during their normal call window. The issue has been resolved and notification are in the process of being delivered.
Posted Apr 18, 2024 - 17:03 CDT
This incident affected: TeleVox Healthcare (ClientTell).