HCPro Experiencing Latency
Incident Report for TeleVox
Resolved
The latency issue has been resolved. An RCA will be available upon request. Our apologies for any inconvenience you may have incurred.
Posted Nov 14, 2024 - 11:41 CST
Investigating
We are currently experiencing some latency on the portal. Multiple teams are engaged and working to resolve this. Updates will be provided as they become available.
Posted Nov 14, 2024 - 10:32 CST
This incident affected: TeleVox Healthcare (HouseCalls Pro).