Appointment Report Not Loading in Analytics (Cerner & HCP)

Incident Report for TeleVox

Resolved

Teams have completed the fix and now all appointment Reports are now loading successfully and the issue has been corrected, and services have been fully restored.
Posted Aug 28, 2026 - 11:40 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 28, 2026 - 11:21 CDT

Investigating

TeleVox is aware of an issue affecting the Appointment Report in Analytics and is actively investigating. In the meantime, appointment statuses remain available in Historic Data. We will provide additional updates as they become available
Posted Aug 28, 2026 - 10:55 CDT
This incident affected: TeleVox Healthcare (HouseCalls Pro).